summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e4a7041..fcf9851 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -148,7 +148,9 @@ if(LUA_FOUND AND PROTOBUF_FOUND)
add_custom_target(
upbc ALL
- DEPENDS ${CMAKE_CURRENT_BINARY_DIR}/tools/upbc
+ DEPENDS ${CMAKE_CURRENT_SOURCE_DIR}/tools/make_c_api.lua
+ ${CMAKE_CURRENT_SOURCE_DIR}/tools/upbc.lua
+ ${CMAKE_CURRENT_BINARY_DIR}/tools/upbc
${CMAKE_CURRENT_BINARY_DIR}/lua/upb.lua
${CMAKE_CURRENT_BINARY_DIR}/lua/upb/pb.lua
)
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback