summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJoshua Haberman <jhaberman@gmail.com>2018-09-03 15:06:43 -0700
committerJoshua Haberman <jhaberman@gmail.com>2018-09-03 15:06:43 -0700
commit694d51f4d6cb8adf4a2f7975e5bb899327875de7 (patch)
tree29ea62eeb151c4cfc739522e19ee30dbee57a137 /CMakeLists.txt
parent41379a7064b6488099f203521fb69ceea0f6cc15 (diff)
Changed C API to only define structs, a table, and a few minimal inline functions.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e4a7041..fcf9851 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -148,7 +148,9 @@ if(LUA_FOUND AND PROTOBUF_FOUND)
add_custom_target(
upbc ALL
- DEPENDS ${CMAKE_CURRENT_BINARY_DIR}/tools/upbc
+ DEPENDS ${CMAKE_CURRENT_SOURCE_DIR}/tools/make_c_api.lua
+ ${CMAKE_CURRENT_SOURCE_DIR}/tools/upbc.lua
+ ${CMAKE_CURRENT_BINARY_DIR}/tools/upbc
${CMAKE_CURRENT_BINARY_DIR}/lua/upb.lua
${CMAKE_CURRENT_BINARY_DIR}/lua/upb/pb.lua
)
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback