summaryrefslogtreecommitdiff
path: root/lang_ext/python/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'lang_ext/python/setup.py')
-rw-r--r--lang_ext/python/setup.py11
1 files changed, 11 insertions, 0 deletions
diff --git a/lang_ext/python/setup.py b/lang_ext/python/setup.py
new file mode 100644
index 0000000..de937c4
--- /dev/null
+++ b/lang_ext/python/setup.py
@@ -0,0 +1,11 @@
+from distutils.core import setup, Extension
+setup(name='upb',
+ version='0.1',
+ ext_modules=[Extension('upb.definition', ['definition.c'],
+ include_dirs=['../../src'],
+ define_macros=[("UPB_USE_PTHREADS", 1),
+ ("UPB_UNALIGNED_READS_OK", 1)],
+ library_dirs=['../../src'],
+ libraries=['upb']
+ )],
+ )
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback