summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 10 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e6bc5b4..2573173 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -64,8 +64,6 @@ add_library(upb
upb/decode.c
upb/encode.c
upb/msg.c
- upb/port_def.inc
- upb/port_undef.inc
upb/table.c
upb/table.int.h
upb/upb.c
@@ -81,6 +79,7 @@ add_library(reflection
upb/msgfactory.h)
target_link_libraries(reflection
descriptor_upbproto
+ table
upb)
add_library(table INTERFACE)
target_link_libraries(table INTERFACE
@@ -89,6 +88,7 @@ add_library(legacy_msg_reflection
upb/legacy_msg_reflection.c
upb/legacy_msg_reflection.h)
target_link_libraries(legacy_msg_reflection
+ table
upb)
add_library(handlers
upb/handlers.c
@@ -98,6 +98,7 @@ add_library(handlers
upb/sink.h)
target_link_libraries(handlers
reflection
+ table
upb)
add_library(upb_pb
upb/pb/compile_decoder.c
@@ -111,7 +112,9 @@ add_library(upb_pb
upb/pb/encoder.h
upb/pb/textprinter.h)
target_link_libraries(upb_pb
+ descriptor_upbproto
handlers
+ reflection
table
upb)
add_library(upb_json
@@ -124,10 +127,15 @@ target_link_libraries(upb_json
upb_pb)
add_library(upb_cc_bindings INTERFACE)
target_link_libraries(upb_cc_bindings INTERFACE
+ descriptor_upbproto
+ handlers
upb)
add_library(upb_test
tests/testmain.cc
tests/test_util.h
tests/upb_test.h)
+target_link_libraries(upb_test
+ handlers
+ upb)
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback