summaryrefslogtreecommitdiff
path: root/upb/bindings/python/setup.py
diff options
context:
space:
mode:
authorJosh Haberman <jhaberman@gmail.com>2014-01-21 18:38:49 -0800
committerJosh Haberman <jhaberman@gmail.com>2014-01-21 18:38:49 -0800
commit0fd2f830882402979a83010e89650e7245960d39 (patch)
tree0968ca9424c5fb2433047519cbd54d3dd8d0b863 /upb/bindings/python/setup.py
parentce9bba3cb5409844f8f3d7dcc235a9ea30cad090 (diff)
Sync to internal Google development.
Diffstat (limited to 'upb/bindings/python/setup.py')
-rw-r--r--upb/bindings/python/setup.py14
1 files changed, 14 insertions, 0 deletions
diff --git a/upb/bindings/python/setup.py b/upb/bindings/python/setup.py
new file mode 100644
index 0000000..8abaff8
--- /dev/null
+++ b/upb/bindings/python/setup.py
@@ -0,0 +1,14 @@
+from distutils.core import setup, Extension
+
+setup(name='upb',
+ version='0.1',
+ ext_modules=[
+ Extension('upb.__init__', ['upb.c'],
+ include_dirs=['../../'],
+ define_macros=[("UPB_UNALIGNED_READS_OK", 1)],
+ library_dirs=['../../upb'],
+ libraries=['upb_pic'],
+ ),
+ ],
+ packages=['upb']
+ )
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback