summaryrefslogtreecommitdiff
path: root/lang_ext/python/setup.py
diff options
context:
space:
mode:
authorJoshua Haberman <joshua@reverberate.org>2009-08-16 12:00:32 -0700
committerJoshua Haberman <joshua@reverberate.org>2009-08-16 12:00:32 -0700
commita223f9af30738cf00c313fabee8de75d04fb9a1a (patch)
treedd8ad3fe6f8280995f69babc83c59666c854186c /lang_ext/python/setup.py
parentf00091f340122f3fc0a3c6d7da2aff8a83f5506d (diff)
More work on Python extension, build libupb PIC.
Diffstat (limited to 'lang_ext/python/setup.py')
-rw-r--r--lang_ext/python/setup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/lang_ext/python/setup.py b/lang_ext/python/setup.py
index de937c4..66862f3 100644
--- a/lang_ext/python/setup.py
+++ b/lang_ext/python/setup.py
@@ -2,10 +2,10 @@ from distutils.core import setup, Extension
setup(name='upb',
version='0.1',
ext_modules=[Extension('upb.definition', ['definition.c'],
- include_dirs=['../../src'],
+ include_dirs=['../../src', '../../descriptor'],
define_macros=[("UPB_USE_PTHREADS", 1),
("UPB_UNALIGNED_READS_OK", 1)],
library_dirs=['../../src'],
- libraries=['upb']
+ libraries=['upb_pic']
)],
)
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback