summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJosh Haberman <jhaberman@gmail.com>2019-04-17 15:23:00 -0700
committerJosh Haberman <jhaberman@gmail.com>2019-04-17 15:23:00 -0700
commitcd9e1e68176e8ec366c8f3b0a42c2d2821676b6f (patch)
treee05da62a3f72e63f13767a3c322233aa0ea5ef80 /CMakeLists.txt
parentf3c560122a8ef25f3391207205c7e55c897fd27f (diff)
upb_proto_library() aspect is working, even for external repos.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index af09f4e..e0c6fbe 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -60,7 +60,6 @@ endif()
enable_testing()
add_library(upb
- google/protobuf/descriptor.upb.c
upb/decode.c
upb/encode.c
upb/msg.c
@@ -69,7 +68,6 @@ add_library(upb
upb/table.c
upb/table.int.h
upb/upb.c
- google/protobuf/descriptor.upb.h
upb/decode.h
upb/encode.h
upb/generated_util.h
@@ -81,6 +79,7 @@ add_library(reflection
upb/def.h
upb/msgfactory.h)
target_link_libraries(reflection
+ descriptor_upbproto
upb)
add_library(table INTERFACE)
target_link_libraries(table INTERFACE
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback