summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJoshua Haberman <jhaberman@gmail.com>2019-06-01 19:27:49 -0700
committerJoshua Haberman <jhaberman@gmail.com>2019-06-01 19:27:49 -0700
commitba29af3a6af9c2e4dfc32ad0230f889e117908b3 (patch)
tree45826d7e62eb36ede8e5fde8cb049ca3dc4e8b58 /CMakeLists.txt
parent9f49efef6203973931894a4ed9b862b3e3d639f0 (diff)
Hid generated-code-only headers inside a separate library.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 7 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2573173..c1c45df 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -63,15 +63,20 @@ enable_testing()
add_library(upb
upb/decode.c
upb/encode.c
+ upb/generated_util.h
upb/msg.c
+ upb/msg.h
+ upb/port_def.inc
+ upb/port_undef.inc
upb/table.c
upb/table.int.h
upb/upb.c
upb/decode.h
upb/encode.h
- upb/generated_util.h
- upb/msg.h
upb/upb.h)
+add_library(generated_code_support__only_for_generated_code_do_not_use__i_give_permission_to_break_me INTERFACE)
+target_link_libraries(generated_code_support__only_for_generated_code_do_not_use__i_give_permission_to_break_me INTERFACE
+ upb)
add_library(reflection
upb/def.c
upb/msgfactory.c
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback