summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJoshua Haberman <jhaberman@gmail.com>2019-04-24 10:54:27 -0700
committerGitHub <noreply@github.com>2019-04-24 10:54:27 -0700
commitb08819749e6c2a6d8d771f954f6162933a8ba648 (patch)
treec80170fc566219ee865a48b3434e399b528cd01f /CMakeLists.txt
parentf9dab27de3f3a77650199da487dd450a49ed35b2 (diff)
parente1fb10002d3ddda0576ab40d3a70065a27baa25a (diff)
Merge pull request #162 from haberman/aspect
Replaced upb_proto_library() with a truly aspect-based rule.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 2 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index af09f4e..3e08cd7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -49,6 +49,7 @@ if(UPB_ENABLE_UBSAN)
endif()
include_directories(.)
+include_directories(generated_for_cmake)
include_directories(${CMAKE_CURRENT_BINARY_DIR})
if(APPLE)
@@ -60,7 +61,6 @@ endif()
enable_testing()
add_library(upb
- google/protobuf/descriptor.upb.c
upb/decode.c
upb/encode.c
upb/msg.c
@@ -69,7 +69,6 @@ add_library(upb
upb/table.c
upb/table.int.h
upb/upb.c
- google/protobuf/descriptor.upb.h
upb/decode.h
upb/encode.h
upb/generated_util.h
@@ -81,6 +80,7 @@ add_library(reflection
upb/def.h
upb/msgfactory.h)
target_link_libraries(reflection
+ descriptor_upbproto
upb)
add_library(table INTERFACE)
target_link_libraries(table INTERFACE
@@ -115,7 +115,6 @@ target_link_libraries(upb_pb
table
upb)
add_library(upb_json
- upb/json/parser.c
upb/json/printer.c
upb/json/parser.h
upb/json/printer.h)
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback