summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJoshua Haberman <jhaberman@gmail.com>2019-05-14 11:12:13 -0700
committerJoshua Haberman <jhaberman@gmail.com>2019-05-14 11:12:13 -0700
commit9b07311c7c0ca0f34f3fea54df478ea6d15dd827 (patch)
tree1df40ff170424d761130df555aec3cbe7457a77d /CMakeLists.txt
parent7913bc678aed392908b2defaf4f5e2e8a5e8599c (diff)
More Blaze fixes.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d085f48..1ff4788 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -79,6 +79,7 @@ add_library(reflection
upb/msgfactory.h)
target_link_libraries(reflection
descriptor_upbproto
+ table
upb)
add_library(table INTERFACE)
target_link_libraries(table INTERFACE
@@ -110,6 +111,7 @@ add_library(upb_pb
upb/pb/encoder.h
upb/pb/textprinter.h)
target_link_libraries(upb_pb
+ descriptor_upbproto
handlers
table
upb)
@@ -123,10 +125,14 @@ target_link_libraries(upb_json
upb_pb)
add_library(upb_cc_bindings INTERFACE)
target_link_libraries(upb_cc_bindings INTERFACE
+ descriptor_upbproto
+ handlers
upb)
add_library(upb_test
tests/testmain.cc
tests/test_util.h
tests/upb_test.h)
+target_link_libraries(upb_test
+ handlers)
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback