summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPaul Yang <TeBoring@users.noreply.github.com>2018-12-04 15:21:32 -0800
committerGitHub <noreply@github.com>2018-12-04 15:21:32 -0800
commit13c59cb051c4deee5367f9c5fc7b5d07363496a0 (patch)
treed71ca4fa8ee5a0feed15eed99f8da51af21aa1d1 /CMakeLists.txt
parent9e44a757edb7ba7155469d3305da32b3dc11c756 (diff)
Implement json decoding for Any message. (#130)
* Implement json decoding for Any message. type url may not appear as the first value in json. As a result, other data cannot be resolved before resolving type url. To solve that, this change caches the start and end position of unparsed values and resolve them in end_any_object when type url has been resolved. * Handle Any in switch * Update json parser size * Fix comments * Sync upstream * Add dependency on upb_pb for upb_json * Debug failed test * Fix cmake * Update test generated files * Remove debug tests
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5c6d5fa..5c78ee0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -116,7 +116,8 @@ add_library(upb_json
upb/json/parser.h
upb/json/printer.h)
target_link_libraries(upb_json
- upb)
+ upb
+ upb_pb)
add_library(upb_cc_bindings
upb/bindings/stdc++/string.h)
target_link_libraries(upb_cc_bindings
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback