summaryrefslogtreecommitdiff
path: root/ts_cpp/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'ts_cpp/setup.py')
-rw-r--r--ts_cpp/setup.py19
1 files changed, 19 insertions, 0 deletions
diff --git a/ts_cpp/setup.py b/ts_cpp/setup.py
new file mode 100644
index 0000000..37111f3
--- /dev/null
+++ b/ts_cpp/setup.py
@@ -0,0 +1,19 @@
+"""Setup script for the Triplet structure C++ extensions.
+
+See https://docs.python.org/3/extending/building.html
+"""
+from distutils.core import setup, Extension
+from glob import glob
+import pybind11
+
+TC_CPP_MODULE = Extension("ts_cpp",
+ include_dirs=[pybind11.get_include()],
+ extra_compile_args=["-O3", "-std=c++11"],
+ sources=glob("*.cc"))
+
+setup(name="ts_cpp",
+ version="1.0",
+ description="Optimized triplet structure extension",
+ author="Matthew A. Sotoudeh",
+ author_email="masotoudeh@ucdavis.edu",
+ ext_modules=[TC_CPP_MODULE])
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback