summaryrefslogtreecommitdiff
path: root/ts_cpp/setup.py
diff options
context:
space:
mode:
authorMatthew Sotoudeh <masotoudeh@ucdavis.edu>2020-11-10 14:16:20 -0800
committerGitHub <noreply@github.com>2020-11-10 14:16:20 -0800
commitde88829eccd369aa1872413d6068d5179468c47e (patch)
tree1947f69081b4f647c643b0f9d5ce8c246a9b097c /ts_cpp/setup.py
parentdb99b3af36fa4687c734e1c74d83157d2f10c9ed (diff)
parentbe64046354a0451869d475e7f0d35f4eb2344c93 (diff)
Initial Code ReleaseHEADmaster
Contains code for reproducing the demos from our Onward '20 paper about Sifter.
Diffstat (limited to 'ts_cpp/setup.py')
-rw-r--r--ts_cpp/setup.py19
1 files changed, 19 insertions, 0 deletions
diff --git a/ts_cpp/setup.py b/ts_cpp/setup.py
new file mode 100644
index 0000000..37111f3
--- /dev/null
+++ b/ts_cpp/setup.py
@@ -0,0 +1,19 @@
+"""Setup script for the Triplet structure C++ extensions.
+
+See https://docs.python.org/3/extending/building.html
+"""
+from distutils.core import setup, Extension
+from glob import glob
+import pybind11
+
+TC_CPP_MODULE = Extension("ts_cpp",
+ include_dirs=[pybind11.get_include()],
+ extra_compile_args=["-O3", "-std=c++11"],
+ sources=glob("*.cc"))
+
+setup(name="ts_cpp",
+ version="1.0",
+ description="Optimized triplet structure extension",
+ author="Matthew A. Sotoudeh",
+ author_email="masotoudeh@ucdavis.edu",
+ ext_modules=[TC_CPP_MODULE])
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback