summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 190a1b1bf..204ea63f8 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -107,6 +107,9 @@ install-data-local:
(echo include/cvc4.h; \
echo include/cvc4_public.h; \
echo include/cvc4parser_public.h; \
+ echo util/tls.h; \
+ echo util/integer.h; \
+ echo util/rational.h; \
find * -name '*.h' | \
xargs grep -l '^# *include *"cvc4.*_public\.h"'; \
(cd "$(srcdir)" && find * -name '*.h' | \
@@ -134,6 +137,9 @@ uninstall-local:
-(echo include/cvc4.h; \
echo include/cvc4_public.h; \
echo include/cvc4parser_public.h; \
+ echo util/tls.h; \
+ echo util/integer.h; \
+ echo util/rational.h; \
find * -name '*.h' | \
xargs grep -l '^# *include *"cvc4.*_public\.h"'; \
(cd "$(srcdir)" && find * -name '*.h' | \
@@ -155,6 +161,9 @@ mostlyclean-local:
(echo include/cvc4.h; \
echo include/cvc4_public.h; \
echo include/cvc4parser_public.h; \
+ echo util/tls.h; \
+ echo util/integer.h; \
+ echo util/rational.h; \
find * -name '*.h.fix' | \
xargs grep -l '^# *include *<cvc4/cvc4.*_public\.h>' | \
sed 's,\.fix$$,,'; \
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback