summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt35
1 files changed, 21 insertions, 14 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index ff11897e9..44b5dfeaf 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -300,18 +300,20 @@ libcvc4_add_sources(
theory/arith/linear_equality.h
theory/arith/matrix.cpp
theory/arith/matrix.h
- theory/arith/nl_constraint.cpp
- theory/arith/nl_constraint.h
- theory/arith/nl_lemma_utils.cpp
- theory/arith/nl_lemma_utils.h
- theory/arith/nl_model.cpp
- theory/arith/nl_model.h
- theory/arith/nl_monomial.cpp
- theory/arith/nl_monomial.h
- theory/arith/nl_solver.cpp
- theory/arith/nl_solver.h
- theory/arith/nonlinear_extension.cpp
- theory/arith/nonlinear_extension.h
+ theory/arith/nl/nl_constraint.cpp
+ theory/arith/nl/nl_constraint.h
+ theory/arith/nl/nl_lemma_utils.cpp
+ theory/arith/nl/nl_lemma_utils.h
+ theory/arith/nl/nl_model.cpp
+ theory/arith/nl/nl_model.h
+ theory/arith/nl/nl_monomial.cpp
+ theory/arith/nl/nl_monomial.h
+ theory/arith/nl/nl_solver.cpp
+ theory/arith/nl/nl_solver.h
+ theory/arith/nl/nonlinear_extension.cpp
+ theory/arith/nl/nonlinear_extension.h
+ theory/arith/nl/transcendental_solver.cpp
+ theory/arith/nl/transcendental_solver.h
theory/arith/normal_form.cpp
theory/arith/normal_form.h
theory/arith/partial_model.cpp
@@ -332,8 +334,6 @@ libcvc4_add_sources(
theory/arith/theory_arith_private.h
theory/arith/theory_arith_private_forward.h
theory/arith/theory_arith_type_rules.h
- theory/arith/transcendental_solver.cpp
- theory/arith/transcendental_solver.h
theory/arith/type_enumerator.h
theory/arrays/array_info.cpp
theory/arrays/array_info.h
@@ -355,6 +355,8 @@ libcvc4_add_sources(
theory/atom_requests.h
theory/booleans/circuit_propagator.cpp
theory/booleans/circuit_propagator.h
+ theory/booleans/proof_checker.cpp
+ theory/booleans/proof_checker.h
theory/booleans/theory_bool.cpp
theory/booleans/theory_bool.h
theory/booleans/theory_bool_rewriter.cpp
@@ -366,6 +368,8 @@ libcvc4_add_sources(
theory/builtin/theory_builtin_rewriter.cpp
theory/builtin/theory_builtin_rewriter.h
theory/builtin/theory_builtin_type_rules.h
+ theory/builtin/proof_checker.cpp
+ theory/builtin/proof_checker.h
theory/builtin/type_enumerator.cpp
theory/builtin/type_enumerator.h
theory/bv/abstraction.cpp
@@ -750,6 +754,8 @@ libcvc4_add_sources(
theory/uf/equality_engine.cpp
theory/uf/equality_engine.h
theory/uf/equality_engine_types.h
+ theory/uf/proof_checker.cpp
+ theory/uf/proof_checker.h
theory/uf/ho_extension.cpp
theory/uf/ho_extension.h
theory/uf/symmetry_breaker.cpp
@@ -923,6 +929,7 @@ install(FILES
expr/datatype.h
expr/emptyset.h
expr/expr_iomanip.h
+ expr/expr_sequence.h
expr/record.h
expr/symbol_table.h
expr/type.h
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback