summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 6 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6c3ed4bbc..3180c780e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -256,9 +256,9 @@ execute_process(COMMAND ${CMAKE_C_COMPILER}
-fuse-ld=gold
-Wl,--version ERROR_QUIET OUTPUT_VARIABLE LD_VERSION)
if ("${LD_VERSION}" MATCHES "GNU gold")
- string(APPEND CMAKE_EXE_LINKER_FLAGS " -fuse-ld=gold")
- string(APPEND CMAKE_SHARED_LINKER_FLAGS " -fuse-ld=gold")
- string(APPEND CMAKE_MODULE_LINKER_FLAGS " -fuse-ld=gold")
+ string(APPEND CMAKE_EXE_LINKER_FLAGS " -fuse-ld=gold -lpthread")
+ string(APPEND CMAKE_SHARED_LINKER_FLAGS " -fuse-ld=gold -lpthread")
+ string(APPEND CMAKE_MODULE_LINKER_FLAGS " -fuse-ld=gold -lpthread")
message(STATUS "Using GNU gold linker.")
endif ()
@@ -453,6 +453,9 @@ endif()
if(ENABLE_PROFILING)
add_definitions(-DCVC4_PROFILING)
add_check_c_cxx_flag("-pg")
+ string(APPEND CMAKE_EXE_LINKER_FLAGS " -pg")
+ string(APPEND CMAKE_SHARED_LINKER_FLAGS " -pg")
+ string(APPEND CMAKE_MODULE_LINKER_FLAGS " -pg")
endif()
if(ENABLE_PROOFS)
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback