summaryrefslogtreecommitdiff
path: root/src/expr/Makefile.am
diff options
context:
space:
mode:
authorMorgan Deters <mdeters@gmail.com>2010-07-04 02:00:42 +0000
committerMorgan Deters <mdeters@gmail.com>2010-07-04 02:00:42 +0000
commitcc726b5080f8926a3cb96a1b9d1098ad8725ab86 (patch)
treee27572b69cefa5cbc2addb6e19c0c5a13e402746 /src/expr/Makefile.am
parent33f1138d8ab09bf133b945647d9239befe297d5e (diff)
make dist && make distcheck functional, other fixes
Diffstat (limited to 'src/expr/Makefile.am')
-rw-r--r--src/expr/Makefile.am82
1 files changed, 37 insertions, 45 deletions
diff --git a/src/expr/Makefile.am b/src/expr/Makefile.am
index db863440c..5f2453898 100644
--- a/src/expr/Makefile.am
+++ b/src/expr/Makefile.am
@@ -10,47 +10,63 @@ libexpr_la_SOURCES = \
node.cpp \
type_node.h \
type_node.cpp \
+ type_constant.h \
node_builder.h \
convenience_node_builders.h \
- @srcdir@/expr.h \
type.h \
type.cpp \
node_value.h \
node_manager.h \
- @srcdir@/expr_manager.h \
attribute.h \
+ attribute_internals.h \
attribute.cpp \
- @srcdir@/kind.h \
- @srcdir@/metakind.h \
node_manager.cpp \
- @srcdir@/expr_manager.cpp \
node_value.cpp \
- @srcdir@/expr.cpp \
command.h \
command.cpp \
declaration_scope.h \
declaration_scope.cpp \
expr_manager_scope.h
+nodist_libexpr_la_SOURCES = \
+ kind.h \
+ metakind.h \
+ expr.h \
+ expr.cpp \
+ expr_manager.h \
+ expr_manager.cpp
EXTRA_DIST = \
- @srcdir@/kind.h \
- @srcdir@/metakind.h \
- @srcdir@/expr_manager.h \
- @srcdir@/expr.h \
- @srcdir@/expr_manager.cpp \
- @srcdir@/expr.cpp \
- @srcdir@/type.h \
- @srcdir@/type.cpp \
kind_template.h \
metakind_template.h \
expr_manager_template.h \
expr_manager_template.cpp \
expr_template.h \
- expr_template.cpp
+ expr_template.cpp \
+ mkkind \
+ mkmetakind \
+ mkexpr
+
+BUILT_SOURCES = \
+ kind.h \
+ metakind.h \
+ expr.h \
+ expr.cpp \
+ expr_manager.h \
+ expr_manager.cpp \
+ $(top_builddir)/src/theory/.subdirs
+
+CLEANFILES = \
+ kind.h \
+ metakind.h \
+ expr.h \
+ expr.cpp \
+ expr_manager.h \
+ expr_manager.cpp \
+ $(top_builddir)/src/theory/.subdirs
include @top_srcdir@/src/theory/Makefile.subdirs
-@srcdir@/kind.h: kind_template.h mkkind @top_builddir@/src/theory/.subdirs @top_srcdir@/src/theory/*/kinds
+kind.h: kind_template.h mkkind @top_builddir@/src/theory/.subdirs @top_srcdir@/src/theory/*/kinds
$(AM_V_at)chmod +x @srcdir@/mkkind
$(AM_V_at)$(am__mv) $@ $@~ 2>/dev/null || true
$(AM_V_GEN)(@srcdir@/mkkind \
@@ -58,7 +74,7 @@ include @top_srcdir@/src/theory/Makefile.subdirs
`cat @top_builddir@/src/theory/.subdirs` \
> $@) || (rm -f $@ && exit 1)
-@srcdir@/metakind.h: metakind_template.h mkmetakind @top_builddir@/src/theory/.subdirs @top_srcdir@/src/theory/*/kinds
+metakind.h: metakind_template.h mkmetakind @top_builddir@/src/theory/.subdirs @top_srcdir@/src/theory/*/kinds
$(AM_V_at)chmod +x @srcdir@/mkmetakind
$(AM_V_at)$(am__mv) $@ $@~ 2>/dev/null || true
$(AM_V_GEN)(@srcdir@/mkmetakind \
@@ -66,7 +82,7 @@ include @top_srcdir@/src/theory/Makefile.subdirs
`cat @top_builddir@/src/theory/.subdirs` \
> $@) || (rm -f $@ && exit 1)
-@srcdir@/expr.h: expr_template.h mkexpr @top_builddir@/src/theory/.subdirs @top_srcdir@/src/theory/*/kinds
+expr.h: expr_template.h mkexpr @top_builddir@/src/theory/.subdirs @top_srcdir@/src/theory/*/kinds
$(AM_V_at)chmod +x @srcdir@/mkexpr
$(AM_V_at)$(am__mv) $@ $@~ 2>/dev/null || true
$(AM_V_GEN)(@srcdir@/mkexpr \
@@ -74,7 +90,7 @@ include @top_srcdir@/src/theory/Makefile.subdirs
`cat @top_builddir@/src/theory/.subdirs` \
> $@) || (rm -f $@ && exit 1)
-@srcdir@/expr.cpp: expr_template.cpp mkexpr @top_builddir@/src/theory/.subdirs @top_srcdir@/src/theory/*/kinds
+expr.cpp: expr_template.cpp mkexpr @top_builddir@/src/theory/.subdirs @top_srcdir@/src/theory/*/kinds
$(AM_V_at)chmod +x @srcdir@/mkexpr
$(AM_V_at)$(am__mv) $@ $@~ 2>/dev/null || true
$(AM_V_GEN)(@srcdir@/mkexpr \
@@ -82,7 +98,7 @@ include @top_srcdir@/src/theory/Makefile.subdirs
`cat @top_builddir@/src/theory/.subdirs` \
> $@) || (rm -f $@ && exit 1)
-@srcdir@/expr_manager.h: expr_manager_template.h mkexpr @top_builddir@/src/theory/.subdirs @top_srcdir@/src/theory/*/kinds
+expr_manager.h: expr_manager_template.h mkexpr @top_builddir@/src/theory/.subdirs @top_srcdir@/src/theory/*/kinds
$(AM_V_at)chmod +x @srcdir@/mkexpr
$(AM_V_at)$(am__mv) $@ $@~ 2>/dev/null || true
$(AM_V_GEN)(@srcdir@/mkexpr \
@@ -90,34 +106,10 @@ include @top_srcdir@/src/theory/Makefile.subdirs
`cat @top_builddir@/src/theory/.subdirs` \
> $@) || (rm -f $@ && exit 1)
-@srcdir@/expr_manager.cpp: expr_manager_template.cpp mkexpr @top_builddir@/src/theory/.subdirs @top_srcdir@/src/theory/*/kinds
+expr_manager.cpp: expr_manager_template.cpp mkexpr @top_builddir@/src/theory/.subdirs @top_srcdir@/src/theory/*/kinds
$(AM_V_at)chmod +x @srcdir@/mkexpr
$(AM_V_at)$(am__mv) $@ $@~ 2>/dev/null || true
$(AM_V_GEN)(@srcdir@/mkexpr \
$< \
`cat @top_builddir@/src/theory/.subdirs` \
> $@) || (rm -f $@ && exit 1)
-
-BUILT_SOURCES = \
- @srcdir@/kind.h \
- @srcdir@/metakind.h \
- @srcdir@/expr.h \
- @srcdir@/expr.cpp \
- @srcdir@/expr_manager.h \
- @srcdir@/expr_manager.cpp
-
-dist-hook: \
- @srcdir@/kind.h \
- @srcdir@/metakind.h \
- @srcdir@/expr.h \
- @srcdir@/expr.cpp \
- @srcdir@/expr_manager.h \
- @srcdir@/expr_manager.cpp
-
-MAINTAINERCLEANFILES = \
- @srcdir@/kind.h \
- @srcdir@/metakind.h \
- @srcdir@/expr.h \
- @srcdir@/expr.cpp \
- @srcdir@/expr_manager.h \
- @srcdir@/expr_manager.cpp
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback