summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMorgan Deters <mdeters@gmail.com>2012-11-12 18:34:32 +0000
committerMorgan Deters <mdeters@gmail.com>2012-11-12 18:34:32 +0000
commit1c2c416b953309279c43c86a46b5690642ff95dd (patch)
tree3cee55cb762199ca28aeceaa589431c064459748 /configure.ac
parent0ba075e240b2083163ab35a3580547cae6927b6c (diff)
* Fix language bindings: various issues
** remove a number of warnings in bindings generation ** give appropriate names for operator-overloading ** make sure Java language bindings are built with -fno-strict-aliasing, to ensure the optimizer doesn't produce bad code * Also remove BitVector::equals(), which wasn't used and was inconsistently implemented (operator==() is still there). (this commit was certified error- and warning-free by the test-and-commit script.)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 940ad43d4..682f0de7c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -743,7 +743,13 @@ AC_SUBST([CVC4_NEED_INT64_T_OVERLOADS])
AC_PROG_ANTLR
CVC4_CXX_OPTION([-Wno-conversion-null], [WNO_CONVERSION_NULL])
+CVC4_CXX_OPTION([-Wno-uninitialized], [WNO_UNINITIALIZED])
+CVC4_CXX_OPTION([-Wno-unused-variable], [WNO_UNUSED_VARIABLE])
+CVC4_CXX_OPTION([-fno-strict-aliasing], [FNO_STRICT_ALIASING])
AC_SUBST([WNO_CONVERSION_NULL])
+AC_SUBST([WNO_UNINITIALIZED])
+AC_SUBST([WNO_UNUSED_VARIABLE])
+AC_SUBST([FNO_STRICT_ALIASING])
# Doxygen configuration
AC_ARG_ENABLE([internals-documentation],
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback