summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt24
1 files changed, 3 insertions, 21 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fb887cb..6133c16 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -72,7 +72,6 @@ add_library(upb
upb/port_undef.inc
upb/refcounted.c
upb/sink.c
- upb/structdefs.int.h
upb/structs.int.h
upb/table.c
upb/table.int.h
@@ -88,29 +87,19 @@ add_library(upb
upb/refcounted.h
upb/sink.h
upb/upb.h)
-add_library(upb_descriptor
- upb/descriptor/descriptor.upbdefs.c
- upb/descriptor/reader.c
- upb/descriptor/descriptor.upbdefs.h
- upb/descriptor/reader.h)
-target_link_libraries(upb_descriptor
- upb)
add_library(upb_pb
upb/pb/compile_decoder.c
upb/pb/decoder.c
upb/pb/decoder.int.h
upb/pb/encoder.c
- upb/pb/glue.c
upb/pb/textprinter.c
upb/pb/varint.c
upb/pb/varint.int.h
upb/pb/decoder.h
upb/pb/encoder.h
- upb/pb/glue.h
upb/pb/textprinter.h)
target_link_libraries(upb_pb
- upb
- upb_descriptor)
+ upb)
add_library(upb_json
upb/json/parser.c
upb/json/printer.c
@@ -132,12 +121,6 @@ add_test(NAME test_varint COMMAND test_varint)
target_link_libraries(test_varint
upb_pb
upb_test)
-add_executable(test_def
- tests/test_def.c)
-add_test(NAME test_def COMMAND test_def)
-target_link_libraries(test_def
- upb_pb
- upb_test)
add_executable(test_handlers
tests/test_handlers.c)
add_test(NAME test_handlers COMMAND test_handlers)
@@ -156,8 +139,8 @@ add_test(NAME test_encoder COMMAND test_encoder)
add_custom_command(
TARGET test_encoder POST_BUILD
COMMAND ${CMAKE_COMMAND} -E copy
- ${CMAKE_SOURCE_DIR}/upb/descriptor/descriptor.pb
- ${CMAKE_CURRENT_BINARY_DIR}/upb/descriptor/descriptor.pb)
+ ${CMAKE_SOURCE_DIR}/google/protobuf/descriptor.pb
+ ${CMAKE_CURRENT_BINARY_DIR}/google/protobuf/descriptor.pb)
target_link_libraries(test_encoder
upb_cc_bindings
upb_pb
@@ -167,7 +150,6 @@ add_executable(test_cpp
add_test(NAME test_cpp COMMAND test_cpp)
target_link_libraries(test_cpp
upb
- upb_descriptor
upb_pb
upb_test)
add_executable(test_table
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback