summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 2 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5c78ee0..30822ce 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -118,11 +118,9 @@ add_library(upb_json
target_link_libraries(upb_json
upb
upb_pb)
-add_library(upb_cc_bindings
- upb/bindings/stdc++/string.h)
-target_link_libraries(upb_cc_bindings
+add_library(upb_cc_bindings INTERFACE)
+target_link_libraries(upb_cc_bindings INTERFACE
upb)
-set_target_properties(upb_cc_bindings PROPERTIES LINKER_LANGUAGE CXX)
add_library(upb_test
tests/testmain.cc
tests/test_util.h
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback