summaryrefslogtreecommitdiff
path: root/lang_ext/python/setup.py
diff options
context:
space:
mode:
authorJoshua Haberman <joshua@reverberate.org>2011-08-08 16:33:48 -0700
committerJoshua Haberman <joshua@reverberate.org>2011-08-08 16:33:48 -0700
commit487bfdfc0603ab7bf5fad381f52b8932cbcd355e (patch)
treed7db8ecbb96f8890e86313153e58edec580337df /lang_ext/python/setup.py
parent6981e468a3234b3f5439dec8178703a6364cfe03 (diff)
Begin port of Python extension to new APIs.
Diffstat (limited to 'lang_ext/python/setup.py')
-rw-r--r--lang_ext/python/setup.py10
1 files changed, 4 insertions, 6 deletions
diff --git a/lang_ext/python/setup.py b/lang_ext/python/setup.py
index ec34e7d..8abaff8 100644
--- a/lang_ext/python/setup.py
+++ b/lang_ext/python/setup.py
@@ -3,12 +3,10 @@ from distutils.core import setup, Extension
setup(name='upb',
version='0.1',
ext_modules=[
- Extension('upb.cext', ['definition.c', 'pb.c', 'cext.c'],
- include_dirs=['../../src', '../../descriptor'],
- define_macros=[("UPB_USE_PTHREADS", 1),
- ("UPB_UNALIGNED_READS_OK", 1),
- ("UPB_THREAD_UNSAFE", 1)],
- library_dirs=['../../src'],
+ Extension('upb.__init__', ['upb.c'],
+ include_dirs=['../../'],
+ define_macros=[("UPB_UNALIGNED_READS_OK", 1)],
+ library_dirs=['../../upb'],
libraries=['upb_pic'],
),
],
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback