summaryrefslogtreecommitdiff
path: root/test/unit/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/unit/Makefile.am')
-rw-r--r--test/unit/Makefile.am23
1 files changed, 8 insertions, 15 deletions
diff --git a/test/unit/Makefile.am b/test/unit/Makefile.am
index 9c1c1c56b..f5ba6f410 100644
--- a/test/unit/Makefile.am
+++ b/test/unit/Makefile.am
@@ -11,43 +11,36 @@ AM_LDFLAGS_WHITE = \
@abs_top_builddir@/src/smt/libsmt.la \
@abs_top_builddir@/src/theory/libtheory.la \
@abs_top_builddir@/src/util/libutil.la \
+ @abs_top_builddir@/src/prop/libprop.la \
@abs_top_builddir@/src/prop/minisat/libminisat.la
AM_LDFLAGS_BLACK = \
$(AM_LDFLAGS_WHITE)
AM_LDFLAGS_PUBLIC = \
@abs_top_builddir@/src/libcvc4.la
-TESTS_WHITE = \
- expr/node_white
-
-TESTS_BLACK = \
- expr/node_black
-
-TESTS_PUBLIC =
-
TESTS = \
- $(TESTS_WHITE) \
- $(TESTS_BLACK) \
- $(TESTS_PUBLIC)
+ expr/node_white \
+ expr/node_black
-lib_LTLIBRARIES = libdummy.la
+# without these here, LTCXXCOMPILE, CXXLINK, etc., aren't set :-(
+noinst_LTLIBRARIES = libdummy.la
libdummy_la_SOURCES = expr/node_black.cpp
libdummy_la_LIBADD = @abs_top_builddir@/src/libcvc4.la
$(TESTS:%=%.cpp): %.cpp: %.h
mkdir -p `dirname "$@"`
@CXXTESTGEN@ --have-eh --have-std --error-printer -o "$@" "$<"
-$(TESTS_WHITE): %: %.cpp
+$(filter %_white,$(TESTS)): %_white: %_white.cpp
# get these in here somehow
# $(TEST_CPPFLAGS) $(TEST_CXXFLAGS) $(TEST_LDFLAGS)
$(LTCXXCOMPILE) $(AM_CXXFLAGS_WHITE) -c -o $@.lo $<
$(CXXLINK) $(AM_LDFLAGS_WHITE) $@.lo
-$(TESTS_BLACK): %: %.cpp
+$(filter %_black,$(TESTS)): %_black: %_black.cpp
# get these in here somehow
# $(TEST_CPPFLAGS) $(TEST_CXXFLAGS) $(TEST_LDFLAGS)
$(LTCXXCOMPILE) $(AM_CXXFLAGS_BLACK) -c -o $@.lo $<
$(CXXLINK) $(AM_LDFLAGS_BLACK) $@.lo
-$(TESTS_PUBLIC): %: %.cpp
+$(filter %_public,$(TESTS)): %_public: %_public.cpp
# get these in here somehow
# $(TEST_CPPFLAGS) $(TEST_CXXFLAGS) $(TEST_LDFLAGS)
$(LTCXXCOMPILE) $(AM_CXXFLAGS_PUBLIC) -c -o $@.lo $<
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback