summaryrefslogtreecommitdiff
path: root/test/unit/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/unit/Makefile.am')
-rw-r--r--test/unit/Makefile.am12
1 files changed, 7 insertions, 5 deletions
diff --git a/test/unit/Makefile.am b/test/unit/Makefile.am
index c145cf752..591a85202 100644
--- a/test/unit/Makefile.am
+++ b/test/unit/Makefile.am
@@ -51,11 +51,6 @@ EXTRA_DIST = \
no_cxxtest \
$(TEST_DEPS_DIST)
-# without these here, LTCXXCOMPILE, CXXLINK, etc., aren't set :-(
-noinst_LTLIBRARIES = libdummy.la
-libdummy_la_SOURCES = expr/node_black.cpp
-libdummy_la_LIBADD = @abs_top_builddir@/src/libcvc4.la
-
MOSTLYCLEANFILES = $(UNIT_TESTS) $(UNIT_TESTS:%=%.cpp)
@mk_include@ @srcdir@/Makefile.tests
@@ -88,6 +83,13 @@ EXTRA_DIST = \
endif
+# trick automake into setting LTCXXCOMPILE, CXXLINK, etc.
+if CVC4_FALSE
+noinst_LTLIBRARIES = libdummy.la
+libdummy_la_SOURCES = expr/node_black.cpp
+libdummy_la_LIBADD = @abs_top_builddir@/src/libcvc4.la
+endif
+
# synonyms for "check"
.PHONY: regress test
regress test: check
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback