summaryrefslogtreecommitdiff
path: root/test/unit/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'test/unit/CMakeLists.txt')
-rw-r--r--test/unit/CMakeLists.txt12
1 files changed, 9 insertions, 3 deletions
diff --git a/test/unit/CMakeLists.txt b/test/unit/CMakeLists.txt
index 4bcb97c8e..d362870c1 100644
--- a/test/unit/CMakeLists.txt
+++ b/test/unit/CMakeLists.txt
@@ -1,3 +1,9 @@
+# Note: We use our custom CxxTest finder here to specify custom directories and
+# fail if it is not found in the specified directory (similar to the other
+# custom finder modules).
+set(CxxTest_HOME ${CXXTEST_DIR})
+find_package(CxxTest REQUIRED)
+
include_directories(.)
include_directories(${PROJECT_SOURCE_DIR}/src)
include_directories(${PROJECT_SOURCE_DIR}/src/include)
@@ -33,9 +39,9 @@ macro(cvc4_add_unit_test is_white name output_dir)
OUTPUT ${test_src}
DEPENDS ${test_header}
COMMAND
- ${CXXTEST_TESTGEN_INTERPRETER}
- ${CXXTEST_TESTGEN_EXECUTABLE}
- ${CXXTEST_TESTGEN_ARGS} -o ${test_src} ${test_header}
+ ${CxxTest_TESTGEN_INTERPRETER}
+ ${CxxTest_TESTGEN_EXECUTABLE}
+ ${CxxTest_TESTGEN_ARGS} -o ${test_src} ${test_header}
)
set_source_files_properties(${test_src} PROPERTIES GENERATED true)
# The build target is created without the path prefix (not supported),
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback