summaryrefslogtreecommitdiff
path: root/test/system/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/system/Makefile.am')
-rw-r--r--test/system/Makefile.am31
1 files changed, 26 insertions, 5 deletions
diff --git a/test/system/Makefile.am b/test/system/Makefile.am
index 61527e4d8..a12adc56b 100644
--- a/test/system/Makefile.am
+++ b/test/system/Makefile.am
@@ -1,5 +1,26 @@
-TESTS_ENVIRONMENT = @top_builddir@/bin/cvc4
-TESTS = \
- simple.cvc \
- simple.smt \
- bug1.cvc
+TESTS_ENVIRONMENT =
+TESTS =
+
+# Things that aren't tests but that tests rely on and need to
+# go into the distribution
+TEST_DEPS_DIST =
+
+# Make-level dependencies; these don't go in the source distribution
+# but should trigger a re-compile of all unit tests. Libraries are
+# included here because (1) if static-linking, the tests must be
+# relinked, and (2) if they've changed that means the sources changed,
+# and that means we should ensure the tests compile against any
+# changes made in the header files.
+TEST_DEPS_NODIST = \
+ $(abs_top_builddir)/src/libcvc4.la \
+ $(abs_top_builddir)/src/parser/libcvc4parser.la
+
+TEST_DEPS = \
+ $(TEST_DEPS_DIST) \
+ $(TEST_DEPS_NODIST)
+
+EXTRA_DIST = \
+ $(TEST_DEPS_DIST)
+
+# rebuild tests if a library changes
+$(TESTS):: $(TEST_DEPS)
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback