summaryrefslogtreecommitdiff
path: root/test/system/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/system/Makefile.am')
-rw-r--r--test/system/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/test/system/Makefile.am b/test/system/Makefile.am
index 15f781333..59a37a4db 100644
--- a/test/system/Makefile.am
+++ b/test/system/Makefile.am
@@ -22,6 +22,17 @@ TEST_DEPS = \
EXTRA_DIST = \
$(TEST_DEPS_DIST)
+if STATIC_BINARY
+system_LINK = $(CXXLINK) -all-static
+else
+system_LINK = $(CXXLINK)
+endif
+
+# WHEN SYSTEM TESTS ARE ADDED, BUILD LIKE THIS:
+# system_test: system_test.cpp
+# $(AM_V_CXX)$(LTCXXCOMPILE) $(AM_CXXFLAGS) -c -o $@.lo $<
+# $(AM_V_CXXLD)$(system_LINK) $(AM_LDFLAGS) $@.lo
+
# rebuild tests if a library changes
$(TESTS):: $(TEST_DEPS)
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback