summaryrefslogtreecommitdiff
path: root/test/regress/regress1/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/regress/regress1/Makefile.am')
-rw-r--r--test/regress/regress1/Makefile.am12
1 files changed, 8 insertions, 4 deletions
diff --git a/test/regress/regress1/Makefile.am b/test/regress/regress1/Makefile.am
index a8483484e..3c88b0b0c 100644
--- a/test/regress/regress1/Makefile.am
+++ b/test/regress/regress1/Makefile.am
@@ -1,10 +1,14 @@
SUBDIRS = . arith
BINARY = cvc4
-if PROOF_REGRESSIONS
-TESTS_ENVIRONMENT = LFSC="$(LFSC) $(LFSCARGS)" @srcdir@/../run_regression $(RUN_REGRESSION_ARGS) --proof @top_builddir@/src/main/$(BINARY)
-else
-TESTS_ENVIRONMENT = @srcdir@/../run_regression $(RUN_REGRESSION_ARGS) @top_builddir@/src/main/$(BINARY)
+LOG_COMPILER = @srcdir@/../run_regression
+AM_LOG_FLAGS = $(RUN_REGRESSION_ARGS) @top_builddir@/src/main/$(BINARY)
+
+if AUTOMAKE_1_11
+# old-style (pre-automake 1.12) test harness
+TESTS_ENVIRONMENT = \
+ $(TESTS_ENVIRONMENT) $(LOG_COMPILER) \
+ $(AM_LOG_FLAGS) $(LOG_FLAGS)
endif
MAKEFLAGS = -k
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback