summaryrefslogtreecommitdiff
path: root/test/regress/regress1/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/regress/regress1/Makefile.am')
-rw-r--r--test/regress/regress1/Makefile.am50
1 files changed, 8 insertions, 42 deletions
diff --git a/test/regress/regress1/Makefile.am b/test/regress/regress1/Makefile.am
index 5f292b893..c399a797f 100644
--- a/test/regress/regress1/Makefile.am
+++ b/test/regress/regress1/Makefile.am
@@ -1,4 +1,4 @@
-SUBDIRS = . arith
+SUBDIRS = . bv aufbv auflia datatypes rewriterules lemmas decision fmf strings sets sygus sep
# don't override a BINARY imported from a personal.mk
@mk_if@eq ($(BINARY),)
@@ -20,50 +20,16 @@ MAKEFLAGS = -k
# These are run for all build profiles.
# If a test shouldn't be run in e.g. competition mode,
# put it below in "TESTS +="
-TESTS = bug136.smt \
- bug148.smt \
- bug394.smt2 \
- DTP_k2_n35_c175_s15.smt2 \
- GEO123+1.minimized.smt2 \
- error1.smt \
- friedman_n4_i5.smt \
- hole7.cvc \
- hole8.cvc \
- instance_1444.smt \
- fuzz_2.smt \
- hash_sat_10_09.smt2 \
- hash_sat_07_17.smt2 \
- ooo.tag10.smt2 \
- hash_sat_06_19.smt2 \
- hash_sat_09_09.smt2 \
- ooo.rf6.smt2 \
- auflia-fuzz06.smt \
- piVC_5581bd.smt2 \
- typed_v1l50016-simp.cvc \
- FIREFLY_3_e2_2236_e7_3681.ec.minimized.smt2 \
- xs-09-16-3-4-1-5.smt \
- xs-09-16-3-4-1-5.decn.smt \
- uflia-error0.smt2
-
-EXTRA_DIST = $(TESTS) \
- FIREFLY_3_e2_2236_e7_3681.ec.minimized.smt2.expect \
- uflia-error0.smt2.expect \
- xs-09-16-3-4-1-5.decn.smt.expect
-
-#if CVC4_BUILD_PROFILE_COMPETITION
-#else
-#TESTS += \
-# error.cvc
-#endif
-#
-# and make sure to distribute it
-#EXTRA_DIST += \
-# error.cvc
+TESTS = bug425.cvc \
+ bug519.smt2 \
+ bug521.smt2
+
+EXTRA_DIST = $(TESTS)
# synonyms for "check" in this directory
.PHONY: regress regress1 test
regress regress1 test: check
# do nothing in this subdir
-.PHONY: regress0 regress2 regress3
-regress0 regress2 regress3:
+.PHONY: regress0 regress2 regress3 regress4
+regress0 regress2 regress3 regress4:
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback