summaryrefslogtreecommitdiff
path: root/test/regress/regress1/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/regress/regress1/Makefile.am')
-rw-r--r--test/regress/regress1/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/test/regress/regress1/Makefile.am b/test/regress/regress1/Makefile.am
index 9a9016e85..f133a272d 100644
--- a/test/regress/regress1/Makefile.am
+++ b/test/regress/regress1/Makefile.am
@@ -1,4 +1,10 @@
+SUBDIRS = .
+
TESTS_ENVIRONMENT = @srcdir@/../run_regression @top_builddir@/src/main/cvc4
+
+# These are run for all build profiles.
+# If a test shouldn't be run in e.g. competition mode,
+# put it below in "TESTS +="
TESTS = friedman_n4_i5.smt \
hole7.cvc \
hole8.cvc \
@@ -6,6 +12,12 @@ TESTS = friedman_n4_i5.smt \
fuzz_1.smt \
fuzz_2.smt
+#if CVC4_BUILD_PROFILE_COMPETITION
+#else
+#TESTS += \
+# error.cvc
+#endif
+
# synonyms for "check"
.PHONY: regress regress1 test
regress regress1 test: check
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback