summaryrefslogtreecommitdiff
path: root/test/regress/regress0/push-pop/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/regress/regress0/push-pop/Makefile.am')
-rw-r--r--test/regress/regress0/push-pop/Makefile.am25
1 files changed, 25 insertions, 0 deletions
diff --git a/test/regress/regress0/push-pop/Makefile.am b/test/regress/regress0/push-pop/Makefile.am
new file mode 100644
index 000000000..ee365e79d
--- /dev/null
+++ b/test/regress/regress0/push-pop/Makefile.am
@@ -0,0 +1,25 @@
+SUBDIRS = .
+
+TESTS_ENVIRONMENT = @srcdir@/../../run_regression @top_builddir@/src/main/cvc4
+MAKEFLAGS = -k
+
+# These are run for all build profiles.
+# If a test shouldn't be run in e.g. competition mode,
+# put it below in "TESTS +="
+
+# Regression tests for SMT inputs
+CVC_TESTS = \
+ test.00.cvc \
+ test.01.cvc
+
+TESTS = $(SMT_TESTS) $(SMT2_TESTS) $(CVC_TESTS) $(BUG_TESTS)
+
+EXTRA_DIST = $(TESTS)
+
+# synonyms for "check"
+.PHONY: regress regress0 test
+regress regress0 test: check
+
+# do nothing in this subdir
+.PHONY: regress1 regress2 regress3
+regress1 regress2 regress3:
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback