summaryrefslogtreecommitdiff
path: root/test/regress/regress0/aufbv/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/regress/regress0/aufbv/Makefile.am')
-rw-r--r--test/regress/regress0/aufbv/Makefile.am31
1 files changed, 31 insertions, 0 deletions
diff --git a/test/regress/regress0/aufbv/Makefile.am b/test/regress/regress0/aufbv/Makefile.am
new file mode 100644
index 000000000..9afa37e46
--- /dev/null
+++ b/test/regress/regress0/aufbv/Makefile.am
@@ -0,0 +1,31 @@
+if PROOF_REGRESSIONS
+TESTS_ENVIRONMENT = LFSC="$(LFSC) $(LFSCARGS)" @srcdir@/../../run_regression $(RUN_REGRESSION_ARGS) --proof @top_builddir@/src/main/cvc4
+else
+TESTS_ENVIRONMENT = @srcdir@/../../run_regression $(RUN_REGRESSION_ARGS) @top_builddir@/src/main/cvc4
+endif
+
+# These are run for all build profiles.
+# If a test shouldn't be run in e.g. competition mode,
+# put it below in "TESTS +="
+TESTS = \
+ bug00.smt
+
+EXTRA_DIST = $(TESTS)
+
+#if CVC4_BUILD_PROFILE_COMPETITION
+#else
+#TESTS += \
+# error.cvc
+#endif
+#
+# and make sure to distribute it
+#EXTRA_DIST += \
+# error.cvc
+
+# synonyms for "check"
+.PHONY: regress regress0 test
+regress regress0 test: check
+
+# do nothing in this subdir
+.PHONY: regress1 regress2 regress3
+regress1 regress2 regress3:
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback