summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am41
1 files changed, 38 insertions, 3 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 316b2a140..31978b3c2 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -1,11 +1,46 @@
-SUBDIRS = unit system regress
+SUBDIRS = unit system regress .
+
+MAKEFLAGS = -k
.PHONY: regress0 regress1 regress2 regress3
regress0 regress1 regress2 regress3:
+ @$(MAKE) check-pre; \
for dir in $(SUBDIRS); do \
- (cd $$dir && $(MAKE) $(AM_MAKEFLAGS) $@) || exit 1; \
- done
+ test $$dir = . || (cd $$dir && $(MAKE) $(AM_MAKEFLAGS) $@); \
+ done; \
+ $(MAKE) check-local
# synonyms for "check"
.PHONY: regress test
regress test: check
+
+am__tty_colors = \
+red=; grn=; lgn=; blu=; std=; \
+test "X$(AM_COLOR_TESTS)" != Xno \
+&& test "X$$TERM" != Xdumb \
+&& { test "X$(AM_COLOR_TESTS)" = Xalways || test -t 1 2>/dev/null; } \
+&& { \
+ red=''; \
+ grn=''; \
+ lgn=''; \
+ blu=''; \
+ std=''; \
+}
+subdirs_to_check = unit system regress/regress0 regress/regress1 regress/regress2 regress/regress3
+check-recursive: check-pre
+.PHONY: check-pre
+check-pre:
+ @rm -f $(subdirs_to_check:=/test-suite.log)
+check-local:
+ @$(am__tty_colors); \
+ echo $${blu}=============================== TESTING SUMMARY =============================$$std; \
+ for log in $(subdirs_to_check:=/test-suite.log); do \
+ if test -s "$$log"; then \
+ status="`head -n 5 $$log | tail -1`"; \
+ if echo "$$status" | grep -q failed; then col=$$red; \
+ else col=$$grn; fi; \
+ echo "$$col$$status"; \
+ echo " @abs_builddir@/$$log$$std"; \
+ fi; \
+ done; \
+ echo $${blu}=============================== TESTING SUMMARY =============================$$std
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback