summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 575d07b77..316b2a140 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -1,5 +1,11 @@
SUBDIRS = unit system regress
+.PHONY: regress0 regress1 regress2 regress3
+regress0 regress1 regress2 regress3:
+ for dir in $(SUBDIRS); do \
+ (cd $$dir && $(MAKE) $(AM_MAKEFLAGS) $@) || exit 1; \
+ done
+
# synonyms for "check"
.PHONY: regress test
regress test: check
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback