summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am13
1 files changed, 8 insertions, 5 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 31978b3c2..de8e7a985 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -34,13 +34,16 @@ check-pre:
check-local:
@$(am__tty_colors); \
echo $${blu}=============================== TESTING SUMMARY =============================$$std; \
- for log in $(subdirs_to_check:=/test-suite.log); do \
+ for dir in $(subdirs_to_check); do \
+ log=$$dir/test-suite.log; \
if test -s "$$log"; then \
status="`head -n 5 $$log | tail -1`"; \
- if echo "$$status" | grep -q failed; then col=$$red; \
- else col=$$grn; fi; \
- echo "$$col$$status"; \
- echo " @abs_builddir@/$$log$$std"; \
+ if echo "$$status" | grep -q failed; then \
+ echo "$$red$$status"; \
+ echo " @abs_builddir@/$$log$$std"; \
+ else \
+ printf "$$grn%-30s in $$dir$$std\\n" "$$status"; \
+ fi; \
fi; \
done; \
echo $${blu}=============================== TESTING SUMMARY =============================$$std
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback