summaryrefslogtreecommitdiff
path: root/src/util/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/util/Makefile.am')
-rw-r--r--src/util/Makefile.am54
1 files changed, 1 insertions, 53 deletions
diff --git a/src/util/Makefile.am b/src/util/Makefile.am
index 432e6ef26..7d3664d47 100644
--- a/src/util/Makefile.am
+++ b/src/util/Makefile.am
@@ -89,52 +89,6 @@ BUILT_SOURCES = \
rational.h \
integer.h \
tls.h
-if CVC4_DEBUG
-if CVC4_TRACING
-# listing Debug_tags too ensures that make doesn't auto-remove it
-# after building (if it does, we don't get the "cached" effect with
-# the .tmp files below, and we have to re-compile and re-link each
-# time, even when there are no changes).
-BUILT_SOURCES += \
- Debug_tags.h \
- Debug_tags
-endif
-endif
-if CVC4_TRACING
-# listing Trace_tags too ensures that make doesn't auto-remove it
-# after building (if it does, we don't get the "cached" effect with
-# the .tmp files below, and we have to re-compile and re-link each
-# time, even when there are no changes).
-BUILT_SOURCES += \
- Trace_tags.h \
- Trace_tags
-endif
-
-%_tags.h: %_tags
- $(AM_V_GEN)( \
- echo 'static char const* const $^[] = {'; \
- for tag in `cat $^`; do \
- echo "\"$$tag\","; \
- done; \
- echo 'NULL'; \
- echo '};' \
- ) >"$@"
-
-# This .tmp business is to keep from having to re-compile options.cpp
-# (and then re-link the libraries) if nothing has changed.
-%_tags: %_tags.tmp
- $(AM_V_GEN)\
- diff -q "$^" "$@" &>/dev/null || mv "$^" "$@" || true
-# .PHONY ensures the .tmp version is always rebuilt (to check for any changes)
-.PHONY: Debug_tags.tmp Trace_tags.tmp
-# The "sed" invocation below is particularly obnoxious, but it works around
-# inconsistencies in REs on different platforms, using only a basic regular
-# expression (no |, no \<, ...).
-Debug_tags.tmp Trace_tags.tmp:
- $(AM_V_GEN)\
- grep '\<$(@:_tags.tmp=)\(\.isOn\)* *( *\".*\" *)' \
- `find @srcdir@/../ -name "*.cpp" -or -name "*.h" -or -name "*.cc" -or -name "*.g"` | \
- sed 's/^$(@:_tags.tmp=)\(\.isOn\)* *( *\"\([^"]*\)\".*/\2/;s/.*[^a-zA-Z0-9_]$(@:_tags.tmp=)\(\.isOn\)* *( *\"\([^"]*\)\".*/\2/' | LC_ALL=C sort | uniq >"$@"
if CVC4_CLN_IMP
libutil_la_SOURCES += \
@@ -181,10 +135,4 @@ DISTCLEANFILES = \
tls.h.tmp \
integer.h \
rational.h \
- tls.h \
- Debug_tags.tmp \
- Debug_tags.h \
- Debug_tags \
- Trace_tags.tmp \
- Trace_tags.h \
- Trace_tags
+ tls.h
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback