summaryrefslogtreecommitdiff
path: root/src/util/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/util/Makefile.am')
-rw-r--r--src/util/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/util/Makefile.am b/src/util/Makefile.am
index f3aba34cd..f5a3b7d00 100644
--- a/src/util/Makefile.am
+++ b/src/util/Makefile.am
@@ -114,9 +114,9 @@ endif
.PHONY: Debug_tags.tmp Trace_tags.tmp
Debug_tags.tmp Trace_tags.tmp:
$(AM_V_GEN)\
- grep '\<$(@:_tags.tmp=) *( *\".*\" *)' \
+ grep '[^a-zA-Z0-9_]$(@:_tags.tmp=) *( *\".*\" *)' \
`find @srcdir@/../ -name "*.cpp" -or -name "*.h" -or -name "*.cc" -or -name "*.g"` | \
- sed 's/.*\<$(@:_tags.tmp=) *( *\"\([^"]*\)\".*/\1/g' | sort | uniq >"$@"
+ sed 's/.*[^a-zA-Z0-9_]$(@:_tags.tmp=) *( *\"\([^"]*\)\".*/\1/g' | sort | uniq >"$@"
if CVC4_CLN_IMP
libutil_la_SOURCES += \
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback