summaryrefslogtreecommitdiff
path: root/src/theory/rewriterules/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/theory/rewriterules/Makefile.am')
-rw-r--r--src/theory/rewriterules/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/src/theory/rewriterules/Makefile.am b/src/theory/rewriterules/Makefile.am
new file mode 100644
index 000000000..46cffda11
--- /dev/null
+++ b/src/theory/rewriterules/Makefile.am
@@ -0,0 +1,19 @@
+AM_CPPFLAGS = \
+ -D__BUILDING_CVC4LIB \
+ -I@srcdir@/../../include -I@srcdir@/../.. -I@builddir@/../..
+AM_CXXFLAGS = -Wall -Wno-unknown-pragmas $(FLAG_VISIBILITY_HIDDEN)
+
+noinst_LTLIBRARIES = librewriterules.la
+
+librewriterules_la_SOURCES = \
+ theory_rewriterules_rules.h \
+ theory_rewriterules_rules.cpp \
+ theory_rewriterules.h \
+ theory_rewriterules.cpp \
+ theory_rewriterules_rewriter.h \
+ theory_rewriterules_type_rules.h \
+ theory_rewriterules_preprocess.h \
+ theory_rewriterules_params.h
+
+EXTRA_DIST = \
+ kinds
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback