summaryrefslogtreecommitdiff
path: root/src/theory/arith/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/theory/arith/Makefile.am')
-rw-r--r--src/theory/arith/Makefile.am28
1 files changed, 24 insertions, 4 deletions
diff --git a/src/theory/arith/Makefile.am b/src/theory/arith/Makefile.am
index 8077148c3..c5b07c3a5 100644
--- a/src/theory/arith/Makefile.am
+++ b/src/theory/arith/Makefile.am
@@ -10,11 +10,11 @@ libarith_la_SOURCES = \
type_enumerator.h \
arithvar.h \
arithvar.cpp \
+ bound_counts.h \
arith_rewriter.h \
arith_rewriter.cpp \
arith_static_learner.h \
arith_static_learner.cpp \
- arithvar_node_map.h \
constraint_forward.h \
constraint.h \
constraint.cpp \
@@ -29,14 +29,34 @@ libarith_la_SOURCES = \
partial_model.cpp \
linear_equality.h \
linear_equality.cpp \
+ simplex_update.h \
+ simplex_update.cpp \
+ callbacks.h \
+ callbacks.cpp \
matrix.h \
matrix.cpp \
- arith_priority_queue.h \
- arith_priority_queue.cpp \
+ tableau.h \
+ tableau.cpp \
+ tableau_sizes.h \
+ tableau_sizes.cpp \
+ error_set.h \
+ error_set.cpp \
simplex.h \
simplex.cpp \
+ dual_simplex.h \
+ dual_simplex.cpp \
+ fc_simplex.h \
+ fc_simplex.cpp \
+ soi_simplex.h \
+ soi_simplex.cpp \
+ approx_simplex.h \
+ approx_simplex.cpp \
+ pure_update_simplex.h \
+ pure_update_simplex.cpp \
theory_arith.h \
theory_arith.cpp \
+ theory_arith_private.h \
+ theory_arith_private.cpp \
dio_solver.h \
dio_solver.cpp \
arith_heuristic_pivot_rule.h \
@@ -44,7 +64,7 @@ libarith_la_SOURCES = \
arith_unate_lemma_mode.h \
arith_unate_lemma_mode.cpp \
arith_propagation_mode.h \
- arith_propagation_mode.cpp
+ arith_propagation_mode.cpp
EXTRA_DIST = \
kinds \
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback