summaryrefslogtreecommitdiff
path: root/src/theory/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/theory/Makefile.am')
-rw-r--r--src/theory/Makefile.am32
1 files changed, 24 insertions, 8 deletions
diff --git a/src/theory/Makefile.am b/src/theory/Makefile.am
index 639e9eb4c..5af56ec44 100644
--- a/src/theory/Makefile.am
+++ b/src/theory/Makefile.am
@@ -18,9 +18,13 @@ libtheory_la_SOURCES = \
shared_term_manager.h \
shared_term_manager.cpp \
shared_data.h \
- shared_data.cpp
+ shared_data.cpp \
+ rewriter.h \
+ rewriter_attributes.h \
+ rewriter.cpp
nodist_libtheory_la_SOURCES = \
- theoryof_table.h
+ rewriter_tables.h \
+ theory_traits.h
libtheory_la_LIBADD = \
@builddir@/builtin/libbuiltin.la \
@@ -31,22 +35,34 @@ libtheory_la_LIBADD = \
@builddir@/bv/libbv.la
EXTRA_DIST = \
- theoryof_table_template.h \
+ rewriter_tables_template.h \
+ theory_traits_template.h \
mktheoryof \
Makefile.subdirs
BUILT_SOURCES = \
- theoryof_table.h
+ rewriter_tables.h \
+ theory_traits.h
CLEANFILES = \
- theoryof_table.h
+ rewriter_tables.h \
+ theory_traits.h
include @top_srcdir@/src/theory/Makefile.subdirs
-theoryof_table.h: theoryof_table_template.h mktheoryof @top_builddir@/src/theory/.subdirs @top_srcdir@/src/theory/*/kinds
- $(AM_V_at)chmod +x @srcdir@/mktheoryof
+rewriter_tables.h: rewriter_tables_template.h mkrewriter @top_builddir@/src/theory/.subdirs @top_srcdir@/src/theory/*/kinds
+ $(AM_V_at)chmod +x @srcdir@/mkrewriter
$(AM_V_at)$(am__mv) $@ $@~ 2>/dev/null || true
- $(AM_V_GEN)(@srcdir@/mktheoryof \
+ $(AM_V_GEN)(@srcdir@/mkrewriter \
$< \
`cat @top_builddir@/src/theory/.subdirs` \
> $@) || (rm -f $@ && exit 1)
+
+theory_traits.h: theory_traits_template.h mktheorytraits @top_builddir@/src/theory/.subdirs @top_srcdir@/src/theory/*/kinds
+ $(AM_V_at)chmod +x @srcdir@/mktheorytraits
+ $(AM_V_at)$(am__mv) $@ $@~ 2>/dev/null || true
+ $(AM_V_GEN)(@srcdir@//mktheorytraits \
+ $< \
+ `cat @top_builddir@/src/theory/.subdirs` \
+ > $@) || (rm -f $@ && exit 1)
+ \ No newline at end of file
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback