summaryrefslogtreecommitdiff
path: root/src/theory/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/theory/Makefile.am')
-rw-r--r--src/theory/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/src/theory/Makefile.am b/src/theory/Makefile.am
index 0d680f4c9..eecf95875 100644
--- a/src/theory/Makefile.am
+++ b/src/theory/Makefile.am
@@ -71,3 +71,15 @@ theory_traits.h: theory_traits_template.h mktheorytraits @top_builddir@/src/theo
$< \
`cat @top_builddir@/src/theory/.subdirs` \
> $@) || (rm -f $@ && exit 1)
+
+AM_V_CHECK = $(am__v_CHECK_$(V))
+am__v_CHECK_ = $(am__v_CHECK_$(AM_DEFAULT_VERBOSITY))
+am__v_CHECK_0 = @echo " CHECK " $@;
+
+.PHONY: theory-properties
+theory-properties:
+ $(AM_V_CHECK)@srcdir@/mktheorytraits \
+ theory_traits_template.h \
+ `cat @top_builddir@/src/theory/.subdirs` \
+ > /dev/null
+all-local check-local: theory-properties
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback