summaryrefslogtreecommitdiff
path: root/src/theory/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/theory/Makefile.am')
-rw-r--r--src/theory/Makefile.am28
1 files changed, 24 insertions, 4 deletions
diff --git a/src/theory/Makefile.am b/src/theory/Makefile.am
index f6f4ae07e..951dbeb78 100644
--- a/src/theory/Makefile.am
+++ b/src/theory/Makefile.am
@@ -6,14 +6,34 @@ AM_CXXFLAGS = -Wall -fvisibility=hidden
noinst_LTLIBRARIES = libtheory.la
libtheory_la_SOURCES = \
+ @srcdir@/theoryof_table.h \
theory_engine.h \
theory_engine.cpp \
theory.h \
theory.cpp
libtheory_la_LIBADD = \
- @builddir@/bool/libbool.la
- @builddir@/uf/libuf.la
- @builddir@/uf/libarith.la
+ @builddir@/booleans/libbooleans.la \
+ @builddir@/uf/libuf.la \
+ @builddir@/arith/libarith.la
-SUBDIRS = bool uf arith
+EXTRA_DIST = \
+ @srcdir@/theoryof_table.h \
+ theoryof_table_prologue.h \
+ theoryof_table_middle.h \
+ theoryof_table_epilogue.h
+
+@srcdir@/theoryof_table.h: @srcdir@/mktheoryof theoryof_table_prologue.h theoryof_table_middle.h theoryof_table_epilogue.h @top_srcdir@/src/theory/Makefile.in @top_srcdir@/src/theory/*/kinds
+ chmod +x @srcdir@/mktheoryof
+ (@srcdir@/mktheoryof \
+ @srcdir@/theoryof_table_prologue.h \
+ @srcdir@/theoryof_table_middle.h \
+ @srcdir@/theoryof_table_epilogue.h \
+ `grep '^SUBDIRS = ' @top_srcdir@/src/theory/Makefile.in | cut -d' ' -f3- | tr ' ' "\n" | xargs -i__D__ echo @top_srcdir@/src/theory/__D__/kinds` \
+ > @srcdir@/theoryof_table.h) || (rm -f @srcdir@/theoryof_table.h && exit 1)
+
+BUILT_SOURCES = @srcdir@/theoryof_table.h
+dist-hook: @srcdir@/theoryof_table.h
+MAINTAINERCLEANFILES = @srcdir@/theoryof_table.h
+
+SUBDIRS = booleans uf arith
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback