summaryrefslogtreecommitdiff
path: root/src/theory/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/theory/CMakeLists.txt')
-rw-r--r--src/theory/CMakeLists.txt14
1 files changed, 11 insertions, 3 deletions
diff --git a/src/theory/CMakeLists.txt b/src/theory/CMakeLists.txt
index ab6dd580f..3259ce6c0 100644
--- a/src/theory/CMakeLists.txt
+++ b/src/theory/CMakeLists.txt
@@ -1,3 +1,9 @@
+libcvc4_add_sources(GENERATED
+ rewriter_tables.h
+ theory_traits.h
+ type_enumerator.cpp
+)
+
file(GLOB kinds_files ${PROJECT_SOURCE_DIR}/src/theory/*/kinds)
set(mktheorytraits_script ${CMAKE_CURRENT_LIST_DIR}/mktheorytraits)
@@ -33,7 +39,9 @@ add_custom_command(
DEPENDS mktheorytraits type_enumerator_template.cpp
)
-add_custom_target(
- gen-theory-files
- DEPENDS type_enumerator.cpp theory_traits.h rewriter_tables.h
+add_custom_target(gen-theory
+ DEPENDS
+ type_enumerator.cpp
+ theory_traits.h
+ rewriter_tables.h
)
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback