summaryrefslogtreecommitdiff
path: root/src/prop/minisat/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/prop/minisat/Makefile.am')
-rw-r--r--src/prop/minisat/Makefile.am32
1 files changed, 22 insertions, 10 deletions
diff --git a/src/prop/minisat/Makefile.am b/src/prop/minisat/Makefile.am
index 56f61adad..3d7bb08df 100644
--- a/src/prop/minisat/Makefile.am
+++ b/src/prop/minisat/Makefile.am
@@ -1,29 +1,41 @@
AM_CPPFLAGS = \
-D__BUILDING_CVC4LIB \
- -I@srcdir@/mtl -I@srcdir@/core -I@srcdir@/../.. -I@builddir@/../.. -I@srcdir@/../../include
-AM_CXXFLAGS = -Wall -Wno-unknown-pragmas $(FLAG_VISIBILITY_HIDDEN) -DNDEBUG
+ -D __STDC_LIMIT_MACROS \
+ -D __STDC_FORMAT_MACROS \
+ -I@srcdir@/ -I@srcdir@/../.. -I@builddir@/../.. -I@srcdir@/../../include
+AM_CXXFLAGS = -Wall -Wno-parentheses -Wno-unknown-pragmas $(FLAG_VISIBILITY_HIDDEN) -DNDEBUG
noinst_LTLIBRARIES = libminisat.la
libminisat_la_SOURCES = \
- core/Solver.C \
+ core/Dimacs.h \
+ core/Solver.cc \
core/Solver.h \
core/SolverTypes.h \
- simp/SimpSolver.C \
+ simp/SimpSolver.cc \
simp/SimpSolver.h \
mtl/Alg.h \
- mtl/BasicHeap.h \
- mtl/BoxedVec.h \
+ mtl/Alloc.h \
mtl/Heap.h \
+ mtl/IntTypes.h \
mtl/Map.h \
mtl/Queue.h \
mtl/Sort.h \
- mtl/Vec.h
+ mtl/Vec.h \
+ mtl/Xalloc.h \
+ util/Options.h
EXTRA_DIST = \
- core/Main.C \
+ core/Main.cc \
core/Makefile \
- simp/Main.C \
+ doc/ReleaseNotes-2.2.0.txt \
+ simp/Main.cc \
simp/Makefile \
README \
LICENSE \
- mtl/template.mk
+ mtl/config.mk \
+ mtl/template.mk \
+ utils/ParseUtils.h \
+ utils/System.h \
+ utils/System.cc \
+ Makefile
+
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback