summaryrefslogtreecommitdiff
path: root/src/prop/minisat/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/prop/minisat/Makefile.am')
-rw-r--r--src/prop/minisat/Makefile.am29
1 files changed, 29 insertions, 0 deletions
diff --git a/src/prop/minisat/Makefile.am b/src/prop/minisat/Makefile.am
new file mode 100644
index 000000000..56f61adad
--- /dev/null
+++ b/src/prop/minisat/Makefile.am
@@ -0,0 +1,29 @@
+AM_CPPFLAGS = \
+ -D__BUILDING_CVC4LIB \
+ -I@srcdir@/mtl -I@srcdir@/core -I@srcdir@/../.. -I@builddir@/../.. -I@srcdir@/../../include
+AM_CXXFLAGS = -Wall -Wno-unknown-pragmas $(FLAG_VISIBILITY_HIDDEN) -DNDEBUG
+
+noinst_LTLIBRARIES = libminisat.la
+libminisat_la_SOURCES = \
+ core/Solver.C \
+ core/Solver.h \
+ core/SolverTypes.h \
+ simp/SimpSolver.C \
+ simp/SimpSolver.h \
+ mtl/Alg.h \
+ mtl/BasicHeap.h \
+ mtl/BoxedVec.h \
+ mtl/Heap.h \
+ mtl/Map.h \
+ mtl/Queue.h \
+ mtl/Sort.h \
+ mtl/Vec.h
+
+EXTRA_DIST = \
+ core/Main.C \
+ core/Makefile \
+ simp/Main.C \
+ simp/Makefile \
+ README \
+ LICENSE \
+ mtl/template.mk
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback