summaryrefslogtreecommitdiff
path: root/src/prop/bvminisat/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/prop/bvminisat/Makefile.am')
-rw-r--r--src/prop/bvminisat/Makefile.am42
1 files changed, 42 insertions, 0 deletions
diff --git a/src/prop/bvminisat/Makefile.am b/src/prop/bvminisat/Makefile.am
new file mode 100644
index 000000000..480e4e83c
--- /dev/null
+++ b/src/prop/bvminisat/Makefile.am
@@ -0,0 +1,42 @@
+AM_CPPFLAGS = \
+ -D__BUILDING_CVC4LIB \
+ -D __STDC_LIMIT_MACROS \
+ -D __STDC_FORMAT_MACROS \
+ -I@srcdir@/ -I@srcdir@/../.. -I@builddir@/../.. -I@srcdir@/../../include
+AM_CXXFLAGS = -Wall -Wno-parentheses -Wno-unknown-pragmas $(FLAG_VISIBILITY_HIDDEN)
+
+noinst_LTLIBRARIES = libbvminisat.la
+libbvminisat_la_SOURCES = \
+ core/Dimacs.h \
+ core/Solver.cc \
+ core/Solver.h \
+ core/SolverTypes.h \
+ simp/SimpSolver.cc \
+ simp/SimpSolver.h \
+ mtl/Alg.h \
+ mtl/Alloc.h \
+ mtl/Heap.h \
+ mtl/IntTypes.h \
+ mtl/Map.h \
+ mtl/Queue.h \
+ mtl/Sort.h \
+ mtl/Vec.h \
+ mtl/XAlloc.h \
+ utils/Options.h
+
+EXTRA_DIST = \
+ core/Main.cc \
+ core/Makefile \
+ doc/ReleaseNotes-2.2.0.txt \
+ simp/Main.cc \
+ simp/Makefile \
+ README \
+ LICENSE \
+ mtl/config.mk \
+ mtl/template.mk \
+ utils/Options.cc \
+ utils/ParseUtils.h \
+ utils/System.h \
+ utils/System.cc \
+ Makefile
+
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback