summaryrefslogtreecommitdiff
path: root/src/proof/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/proof/Makefile.am')
-rw-r--r--src/proof/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/src/proof/Makefile.am b/src/proof/Makefile.am
new file mode 100644
index 000000000..d657dfa80
--- /dev/null
+++ b/src/proof/Makefile.am
@@ -0,0 +1,18 @@
+AM_CPPFLAGS = \
+ -D__BUILDING_CVC4LIB \
+ -D __STDC_LIMIT_MACROS \
+ -D __STDC_FORMAT_MACROS \
+ -I@srcdir@/../include -I@srcdir@/.. -I@builddir@/.. -I@srcdir@/../prop/minisat
+AM_CXXFLAGS = -Wall -Wno-parentheses -Wno-unknown-pragmas $(FLAG_VISIBILITY_HIDDEN)
+
+noinst_LTLIBRARIES = libproof.la
+
+libproof_la_SOURCES = \
+ proof.h \
+ sat_proof.h \
+ sat_proof.cpp \
+ cnf_proof.h \
+ cnf_proof.cpp \
+ proof_manager.h \
+ proof_manager.cpp
+
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback