summaryrefslogtreecommitdiff
path: root/src/parser/tptp/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/parser/tptp/CMakeLists.txt')
-rw-r--r--src/parser/tptp/CMakeLists.txt22
1 files changed, 20 insertions, 2 deletions
diff --git a/src/parser/tptp/CMakeLists.txt b/src/parser/tptp/CMakeLists.txt
index bee38ce87..22593e7b2 100644
--- a/src/parser/tptp/CMakeLists.txt
+++ b/src/parser/tptp/CMakeLists.txt
@@ -1,9 +1,27 @@
-add_custom_target(AntlrTptp
+set(parser_tptp_src_files
+ tptp.cpp
+ tptp.h
+ tptp_input.cpp
+ tptp_input.h
+)
+
+set(parser_tptp_gen_src_files
+ TptpLexer.c
+ TptpParser.c
+)
+
+add_custom_command(
+ OUTPUT ${parser_tptp_gen_src_files} TptpLexer.h TptpParser.h Tptp.tokens
COMMAND
${ANTLR_BINARY}
${CMAKE_CURRENT_SOURCE_DIR}/Tptp.g
-fo ${CMAKE_CURRENT_BINARY_DIR}
+ 2> /dev/null # Ignore Antlr3 warnings
DEPENDS
Tptp.g
)
-#add_dependencies(... AntlrTptp)
+
+add_library(parsertptp SHARED ${parser_tptp_src_files} ${parser_tptp_gen_src_files})
+set_target_properties(parsertptp PROPERTIES COMPILE_DEFINITIONS __BUILDING_CVC4PARSERLIB)
+set_source_files_properties(${parser_tptp_gen_src_files} PROPERTIES LANGUAGE CXX)
+add_dependencies(parsertptp expr)
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback