summaryrefslogtreecommitdiff
path: root/src/parser/tptp/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/parser/tptp/CMakeLists.txt')
-rw-r--r--src/parser/tptp/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/src/parser/tptp/CMakeLists.txt b/src/parser/tptp/CMakeLists.txt
index 22593e7b2..aadd47a2a 100644
--- a/src/parser/tptp/CMakeLists.txt
+++ b/src/parser/tptp/CMakeLists.txt
@@ -21,7 +21,7 @@ add_custom_command(
Tptp.g
)
-add_library(parsertptp SHARED ${parser_tptp_src_files} ${parser_tptp_gen_src_files})
-set_target_properties(parsertptp PROPERTIES COMPILE_DEFINITIONS __BUILDING_CVC4PARSERLIB)
+add_library(parsertptp ${parser_tptp_src_files} ${parser_tptp_gen_src_files})
+target_compile_definitions(parsertptp PRIVATE -D__BUILDING_CVC4PARSERLIB)
set_source_files_properties(${parser_tptp_gen_src_files} PROPERTIES LANGUAGE CXX)
-add_dependencies(parsertptp expr)
+target_link_libraries(parsertptp expr)
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback