summaryrefslogtreecommitdiff
path: root/src/parser/smt/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/parser/smt/Makefile.am')
-rw-r--r--src/parser/smt/Makefile.am14
1 files changed, 6 insertions, 8 deletions
diff --git a/src/parser/smt/Makefile.am b/src/parser/smt/Makefile.am
index 59782de7e..35b5bafd7 100644
--- a/src/parser/smt/Makefile.am
+++ b/src/parser/smt/Makefile.am
@@ -10,19 +10,17 @@ libparsersmt_la_SOURCES = \
AntlrSmtLexer.hpp \
AntlrSmtLexer.cpp \
AntlrSmtParser.hpp \
- AntlrSmtParser.cpp
+ AntlrSmtParser.cpp
BUILT_SOURCES = \
AntlrSmtLexer.hpp \
AntlrSmtLexer.cpp \
AntlrSmtParser.hpp \
AntlrSmtParser.cpp
+CLEAN_FILES = $(BUILT_SOURCES)
+AntlrSmtLexer.cpp AntlrSmtLexer.hpp: SmtLexer.g
+ $(ANTLR) -o "@builddir@" "@srcdir@/SmtLexer.g"
-AntlrSmtLexer.hpp: SmtLexer.g
-AntlrSmtLexer.cpp: SmtLexer.g
- $(ANTLR) @srcdir@/SmtLexer.g
-
-AntlrSmtParser.hpp: SmtParser.g AntlrSmtLexer.cpp
-AntlrSmtParser.cpp: SmtParser.g AntlrSmtLexer.cpp
- $(ANTLR) @srcdir@/SmtParser.g
+AntlrSmtParser.cpp AntlrSmtParser.hpp: SmtParser.g
+ $(ANTLR) -o "@builddir@" "@srcdir@/SmtParser.g"
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback