summaryrefslogtreecommitdiff
path: root/src/parser/smt/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/parser/smt/Makefile.am')
-rw-r--r--src/parser/smt/Makefile.am14
1 files changed, 10 insertions, 4 deletions
diff --git a/src/parser/smt/Makefile.am b/src/parser/smt/Makefile.am
index 54e3e9bf9..bb2018e2e 100644
--- a/src/parser/smt/Makefile.am
+++ b/src/parser/smt/Makefile.am
@@ -1,6 +1,12 @@
-SOURCES = \
+INCLUDES = -I@srcdir@/../include -I@srcdir@/..
+AM_CXXFLAGS = -Wall -fvisibility=hidden
+AM_CPPFLAGS = -D__BUILDING_CVC4LIB
+
+noinst_LTLIBRARIES = libparsersmt.la
+
+libparsersmt_la_SOURCES = \
SmtLexer.g \
- SmtParser.g
+ SmtParser.g \
SmtLexer.hpp \
SmtLexer.cpp \
SmtParser.hpp \
@@ -13,7 +19,7 @@ BUILT_SOURCES = \
SmtParser.cpp
SmtLexer.cpp SmtLexer.hpp: SmtLexer.g
- $(ANTLR) SmtLexer.g
+ $(ANTLR) @srcdir@/SmtLexer.g
SmtParser.cpp SmtParser.hpp: SmtParser.g
- $(ANTLR) SmtParser.g
+ $(ANTLR) @srcdir@/SmtParser.g
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback